Jump to content
Premium Aquatics Aquarium Supplies

RODI 7 stages and 9ppm. HELP


Recommended Posts


I recently upgraded my RODI unit. 

I added a second membrane and have 2x100GPD membranes. I also got the 800ml restrictor for the unit. 


The problem:

despite what I believe to be the correct plumbing, but my brain is so fried from trying so many different options, once I landed on this "final" configuration. After flushing the membranes for 1hr as suggested. My TDS still reads 41ppm going INTO the DI resin and 8ppm coming out of the DI Resin. 

Now at this point I don't know if I connected something wrong or if the TDS meter is out of whack and needs calibration. It could also be both. At this point I need the help of the community on this one. I am currently disabled (pending surgery) and my time bending down is limited so I really want to make it count when I do go back down there under the sink. I know I am pulling at heart strings here LOL but I could really use some advice. 


I did notice there are two elbows that are connected to the 2nd membrane that have a leak. At one point I had to redo the entire configuration, because I wasn't producing ANY waste water... which was weird.... turned out one of the elbows with restrictor on it, i placed in the wrong place... so once I figured that out I was able to determine the TDS in and out of the DI resin as well as take note of those leaks. I don't know if those leaks would produce 8-9ppm but who knows?

Also what is weird, according to my municipal water supply it comes down with 41.5TDS so it's not even that bad to begin with, of course I like to add another 50ppm just in case, because there HAS to be some sediment pickup from the supply to the house, right? like debris in the city tubes etc? well at least that is where my imagination takes me. 

Either way, I should be producing 0TDS water... so perhaps the TDS reader is off too you know? since the INPUT or first reader, which I placed AFTER the sediment,2carbon,2membranes, and it reads 41. So either the TDS is off or the water is much dirtier than 41.5tds as the city suggests. or all of the above LOL...





The filter is:


1 x 1 Micron - 2.5" x 10" Sediment Filter - Neo-Pure

2 x BRS Universal Carbon Block Filter - 1 Micron $0.00


HM DM-2 Deluxe Dual-inline TDS Meter (input)


2 x One Cartridge Refill (1.25 lbs.) DI Resin


HM DM-2 Deluxe Dual-inline TDS Meter (output)



more specifically:

City Water - Sediment Filter - 1x Carbon Block - 2x Carbon Block - TDS in - into flow restrictor IN, leaves OUT into Membrane1 - (Membrane1 waste output to Membrane2 input - Membrane1 product output into (Y)Splitter) - (Membrane 2 waste output into 800ml flush valve - Membrane 2 product output into (Y)Splitter) - (Y)Splitter into flow restrictor IN - Flow restrictor OUT into 2-way - (way1 into DI Resin) - (way 2 into Drinking container)









Link to comment

I don't think so, I don't have a gauge, but I know what 60psi feels like and this is like twice that. I could be wrong but I really don't think it's the pressure. I mean, if it is all I can think of are the elbows that are leaking at a rate of about 1 drop per minute, both from the same membrane. I think I will ahve to buy new elbows for the membrane to eliminate that factor. but when the water is running flush through the waste line, the pressure is insane you could take a shower under that LOL. 

Link to comment

Very frustrating. Just shooting in the dark here, but a few things I would check to see if this helps. 


Is your sediment filter dirty or is your carbon exhausted? If so, I would replace. If new, I would ensure all is tightly secured to the system and ensure it is set up in the order of sediment filter, carbon, RO, DI - All things to check.


For reference, I have the 5 stage BRS unit (75) and this is how I have it set...

Source Water ->, pre filters (sediment, 2x carbon),  -> RO, -> PSI gauge and membrane intake, ->  waste line to Flush Membrane then to drain, and membrane output line to TDS reader input 1 and DI stage -> DI resin output to TDS reader input 2. 


In addition, just making sure you are also using the flush membrane? 



  • Like 1
Link to comment

Certainly continue to be on the lookout for setup problems.  But water pressure is another likely culpit.


Many households only have 40 psi for water pressure....which is about the minimum to drive one RO membrane in a decent manner.  


Of course when we add a second membrane, that would mean 40 psi ÷ 2 = 20 psi per membrane.  


Even if you had the max pressure on tap, which should be less than 80 psi, the second membrane would make that no more than 40 psi per membrane.  


Something closer to 80 psi per membrane is usually considered optimal, but your membrane supplier should specify or rate their membranes so you can look it up.


A booster pump may help if this turns out to be (part of) the problem.

  • Like 1
Link to comment

all is new, new sediment filter, new carbon blocks, new di resin, new 100GPD membranes. 

basically everything except for the canisters


I tried a few configurations with the TDS meter, I figured out that both probes work at least they both give out the same reading when connected to the same line. 


I also removed on membrane and tried to see if that would remove the last of the 6or7ppm TDS. but it did not. 


So I then put the TDS meter beforen and after the DI Resin... it suprised me to see that from 8ppm it only went down to 7ppm...

I did notice, at a point when I removed the DI Resin to shake up the containers, when the water was filling up again, there was a lot of air in the DI canisters. if you flip the DI unt (aka the 2 canisters


I moved the TDS meters around and found out both probes work, if they are misscalibrated they are misscalibrated exactly the same, since they both read the same ppm from the same line. 

So that is discarded.


Then I moved on to the DI Resin.... unpacked and repacked it. I added a flow restrictor to the end of the product line, because I wanted to create pressure inside the DI Resin canisters and remove all air... so i was successful in doing so and saw the water creep up the resin cartridges. So That has been discarded. 


I did notice this however, when applying pressure to the DI Resin. See if this says anything to anyone. When the pressure was on in the di resin canisters, the TDS out read 5ppm... when i released it, while the pressure was at max, it would spit down to 2ppm. 

BUT... at the same time I would hear air bubbles inside one of the membranes.


I tried running the system without the membrane that was making the air bubble sound and still 5 to 8 ppm. I can't figure out what is happening here. I have wasted so much water I feel beyond guilty. When initially all I wanted was to SAVE water.... 


so not only have I wasted water and enough money that I could have purchased a new entire rodi system... so frustrating. Now I have to drive to the LFS and BUY RODI water... this is insane!

  • Sad 1
Link to comment

ahhhhhhhhhhhhh I figured it out everyone! to anyone that cares... LOL... 


turns out the DI resin was upside down.... yeah... go ahead .. laugh it off... point your fingers at the water idiot LMAO 🤣


but anyway safe to say I am now producing 200GPD 0TDS water. the flow is amazing, The filter makes more product water than waster water, pretty cool!

  • Like 3
Link to comment

well it was more the community, I did everything everyone threw at me and we finally hit it on the head


pretty cool to be a part of this community!


thanks again to everyone who chipped in and cared.


Happy Reefing!!

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recommended Discussions

  • Create New...