Jump to content
Jlemunyon

JBJ 28G NanoCube

Recommended Posts

Jlemunyon

One of the pumps in my 28G JBJ NanoCube in not working.  I can't get it out of the back of the tank to look at it.  Can someone help?

Share this post


Link to post
Christopher Marks

Welcome to the community @Jlemunyon! You will need to disconnect some of the plumbing to remove the return pump, carefully but firmly pull the elbow away from the dividing wall to disconnect it. If you need a replacement, the Cobalt Aquatics MJ900 is a commonly used replacement (formerly sold as Marineland MJ900). https://premiumaquatics.com/products/cobalt-aquatics-power-head-mj900-230-gph.html

Share this post


Link to post
Jlemunyon

Thanks for the info.  We were not sure if the plumbing could be disconnected.  The pump seems stuck to the bottom and we can't reach that far to get to it.

 

Share this post


Link to post
Christopher Marks
30 minutes ago, Jlemunyon said:

Thanks for the info.  We were not sure if the plumbing could be disconnected.  The pump seems stuck to the bottom and we can't reach that far to get to it.

The may be stuck to the bottom with suction cups too. Unfortunately you might have to pull up on the power cord to get it free, but sounds like the pump might be due for replacement anyways.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recommended Discussions

×
×
  • Create New...