Jump to content
ReefCleaners.org

Tek fixture works than doesn't wtf is this


Snapper

Recommended Posts

So check this out...

 

I bought a Tek used 4x39 light fixture and something weird is up.

 

1) I didnt notice that it doesnt have the grounder plugs on both power cords, seems to be pulled out. Do I "need" this to fucntion right or its okay?

 

2) try to follow me on this one, might be tough and confusing..

 

lets say this is the order bulb socked 1, 2, 3, 4...all 4 light up.

3 of them are ATI Blue plus, 1 is actinic blue no name from the looks of it, the no namer is in socked 3.

 

If I take socket 3 bulb out and switch it wiht any of the other ones then try to turn it on, socked 2 and 3 dont light up. If I put that no name brand back into socket 3, than socked 2 and 3 work.

 

I cleaned up the reflectors a bit wiht a damp napkin as its full of salt stains which didnt get removed much at all but after I put the socked 3 no name brand lamp into socked 2 just to try agian it worked.

 

It isnt reliable but its working.

 

What coudl be the problem for htis and is it an easy fix?

Link to comment

are you sure youve got the right bulbs in there?., There is a difference between t5 and t5HO. I think over powered bulbs could cause an issue like this., either that or you have some kind of short thats being bridged by the bulb.

Link to comment

Welp.,., If I had just bought a used light fixture.,., first thing I would do is replace all of those bulbs., god knows how old they are or what theyve been put through.., Beyond that., If youve got salt on your reflectors youve almost certainly got salt (at least some) into your connectors., I would take it apart and attempt to clean it., Use q tips and rubbing alcohol., not water. And let it sit for a good few hours to completely dry before plugging it back in.

Link to comment

the 2 cons here are...he took the grounder out and one bulb just needs some tapping to work. outside of that I can't complain on the condition. Its a tough situation I am in

 

the cheap one barely even lights up...it isnt evne blue anymore loll...

 

when I run it with rubbing alcohol, do I go over it wiht water or just let that rubbing alcohol dry out on its own?

 

I need to figure out what bulb colors I want and from where before I place the order.

Gotta be soon though becasue I need salt asap too so Probably order all those together at once.

 

Welp.,., If I had just bought a used light fixture.,., first thing I would do is replace all of those bulbs., god knows how old they are or what theyve been put through.., Beyond that., If youve got salt on your reflectors youve almost certainly got salt (at least some) into your connectors., I would take it apart and attempt to clean it., Use q tips and rubbing alcohol., not water. And let it sit for a good few hours to completely dry before plugging it back in.
Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recommended Discussions

×
×
  • Create New...