Jump to content
Pod Your Reef

Why is the pico aquariums sponsor thread gone?


Mitch619

Recommended Posts

Anyone know? I found it strange. all of the threads started there are also gone.

 

This means the official thread is gone. Maybe we should start another one.

Link to comment
Anyone know? I found it strange. all of the threads started there are also gone.

 

 

Maybe they are no longer a sponsor?

Link to comment
Deleted User 4

Hmmmm weird........I checked my subscribed threads that I had subscribed long ago for picO...there were a couple and now that I check it..... IT'S GONE!! WTHHH What happened???

Link to comment

Yeah, I guess so. But some stuff there was excellent marketing material. The owner's thread contained many of his tanks.

 

I guess since chris is out for the summer he didn't want to pay any fees that had to do with the business. I estimate the owner's thread brought a good amount of business to him though.

Link to comment
Deleted User 4
Yeah, I guess so. But some stuff there was excellent marketing material. The owner's thread contained many of his tanks.

 

I guess since chris is out for the summer he didn't want to pay any fees that had to do with the business. I estimate the owner's thread brought a good amount of business to him.

 

Yeah, that too. His profile is still here. Chris Delicath

:)

Link to comment

Do any of you guys with tanks from PicoAquariums experience issues when adding top off water? My water level will be just above the pump and I'll add a cup of water and forwhatever reason it just raises chamber 2 until I turn off the system and turn it back on , than it generally helps.chris suggested I took out the water level piece so I have done that since day one , I have also removed the filtration box and added a little rock rumble with piece of filtration floss on top of that.just curious if you guys had any thoughts or suggestions or experienced same. I have also a

Tried adding directly to 3 chamber, doesn't help.

Other than that, tank seems to be doing great.

Link to comment

Although not a PicO troubleshooting thread..

 

Yes, take out the sponge between chamber 2 and 3. It probably needs to be cleaned, or removed all together.

 

 

 

P.S. I too am sad to see the threads gone. Wonder whats up with that.

Link to comment
revaltion131

Saw on his site that he (the business) was taking the summer off. I'm figuring it has something to do with that.

Link to comment

He takes the summer off, thus no sponsorship. No sponsorship no special thread area. CM may get that back up form the archives when he comes back in the fall to sell and sponsor again.

Link to comment
Although not a PicO troubleshooting thread..

 

Yes, take out the sponge between chamber 2 and 3. It probably needs to be cleaned, or removed all together.

 

 

 

P.S. I too am sad to see the threads gone. Wonder whats up with that.

 

Well dammit I'm using this as a pico trouble shooting thread ;)good call, it helped.

 

He's married w a baby, this was a secondary business he was trying to get off the ground , fam is first we know he wouldn't take his threads off but that's pretty shotty if NR to take them off because he is no longer a financial sponsor. Who knows?????

Link to comment
but that's pretty shotty if NR to take them off because he is no longer a financial sponsor. Who knows?????

 

no sponsor no special thread area. Pretty simple if you know how the software works

Link to comment
PicO Aquariums

Have no fear guys! just gone for the summer.

cutting the sponsorship during this time saves me money but more so it just doesn't make sense to advertise products people cant buy. You guys are welcome to hit me up with any questions on here or through the website. Keep in mind I am slammed with orders prior to shutting down still but I will get back to you.

Link to comment
PicO Aquariums
Well dammit I'm using this as a pico trouble shooting thread ;)good call, it helped.

 

He's married w a baby, this was a secondary business he was trying to get off the ground , fam is first we know he wouldn't take his threads off but that's pretty shotty if NR to take them off because he is no longer a financial sponsor. Who knows?????

 

Hey George. Yours is doing that because of the huge difference in water volume between the filtration and the display area. Being a custom unit the filtration is basically pumping the water out to the display quickly and the restriction of the filtration chambers,sponge,floss and whatnot are causing a delay in water level balance.

Lower GPH pump would solve the issue but filter your system at a slower rate.

This is the trade off with AIO systems:

Smaller/hidden filtration= slower turnover

Larger/unsightly filtration= higher turnover

 

In the end your still getting clean water out just not as fast as you would have with a full length filtration box.

This is one of the great battles I face with designing these little picos and the smaller the tank the harder it gets. BTW i'm ok with you sending me a few updated pic's of that bad boy when you get time :P

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recommended Discussions

×
×
  • Create New...