Jump to content


Photo

Hagen Fluval E-Series Electronic Aquarium Heater


  • Please log in to reply
4 replies to this topic

#1
Seiryoku

Seiryoku

    Nano Reefer

  • Members
  • 6,160 posts
  • Joined 01 May 2006
  • Sacramento, CA

I have a 50w in my Nuvo 16 (12.5g of water in it right now) and this heater can't get above 75! I know others that use a 50w in their Nuvo 16 with no issues.

Anyone ever have, or hear of, these heaters being weak? I've got it in a high flow area tilted at an angle...have tried horizontal, vertical and every other way of mounting it in a Nuvo. Just seems to be too weak...

#2
jedimasterben

jedimasterben

    LED world domination!

  • Premium Members
  • 20,243 posts
  • Joined 18 Jan 2012
  • Okeechobee, FL

I have a 50w in my Nuvo 16 (12.5g of water in it right now) and this heater can't get above 75! I know others that use a 50w in their Nuvo 16 with no issues.

Anyone ever have, or hear of, these heaters being weak? I've got it in a high flow area tilted at an angle...have tried horizontal, vertical and every other way of mounting it in a Nuvo. Just seems to be too weak...

Well, if you keep it in a room that is cold, it'll have to work harder all the time to get it up to temperature. What is the ambient temp?

#3
Seiryoku

Seiryoku

    Nano Reefer

  • Members
  • 6,160 posts
  • Joined 01 May 2006
  • Sacramento, CA

Well, if you keep it in a room that is cold, it'll have to work harder all the time to get it up to temperature. What is the ambient temp?


About 72 during the day, little colder at night o_o

Edited by Seiryoku, 12 March 2012 - 10:08 AM.


#4
jedimasterben

jedimasterben

    LED world domination!

  • Premium Members
  • 20,243 posts
  • Joined 18 Jan 2012
  • Okeechobee, FL
Hmm. The heater may not function properly.

#5
disaster999

disaster999

    dimsum

  • Members
  • 6,088 posts
  • Joined 22 Aug 2007
  • Hong Kong
i wouldnt blame the heater. its probably not big enough for your tank. i have a 50W heater in a 8gal ADA tank and my heater is constantly on, it cant reach its preset temp. the thing steams up and gets pretty hot when i take it out of the water tho. the heater just isnt big enough to heat the water.

do you have the plastic casing on the heater? try taking them off and see if you;ll get better flow that way.

i have a fluval 200 and it keeps the temp pretty much dead stable.

Edited by disaster999, 14 March 2012 - 01:19 AM.