Jump to content

Walshrus

Members
  • Content count

    5
  • Joined

  • Last visited

About Walshrus

  • Rank
    New Community Member
  1. Unknown hermit, possible leucistic?

    Hravanii, that is exactly what mine looks like! I figured it was some kid of color morph, I was just curious if anyone else had encountered it before.
  2. Hey guys so a couple weeks ago I went to my LFS to pick up some hermits, I got 10 scarlets, took them home acclimated and added to tank. As I was watching them, I noticed one was a bit different. It is the same size as a scarlet, however, it is all white, looks like it has almost fur on all its appendages, and it's antennae and eye stalks are striped black and white, claw size is identical. I looked online and couldn't find any species with a similar description to this, so the only thing I could think of is a possible leucistic or albino, anyone have any ideas?
  3. Cloudy Water

    Ok I will slowly remove that then, my nitrates nitrites and ammonia all read 0 that's why I wasn't sure if it was a bacteria bloom or not.
  4. Cloudy Water

    I have been using RODI water, when I say the tank is cloudy, it isn't a greenish tint from algae, it is distinctly a milky color. I only feed once a day and I have a pretty good CUC in there so I'm not sure how there would be so much extra nutrients. The first month I had the tank I was doing biweekly water changes, since then I have been doing them weekly so I don't think it's a lack of doing water changes either. I also have the jbj nano glo on the bank for the mini refugium I have a ball of chaeto some live rock rubble and the mechanical sponge, I removed the carbon, should I put that back in?
  5. Cloudy Water

    Hey guys, I am new to the forums here. I have had saltwater aquariums before, but the last one I had was about 5 years ago so I am a bit rusty. I mainly have reptiles and amphibians but I decided I wanted to get back into saltwater. I bought a JBJ Nano cube CF Quad, it's 28 gallons I believe. It has been up for about 2 or 3 months now, with 40lbs of live sand and about 40-45 lbs of live rock, a euro nano skimmer, and some chaeto. My current fish stock is a yellow clown goby, a red striped goby, catalina goby, and a gold neon goby. I also have a peppermint shrimp, emerald crab and then a bunch of hermits and snails. All my parameters are at 0 (I literally just checked again before I posted this topic.) I am currently going through an algae bloom, was brown now it's green, but suddenly about 3 days ago maybe the water is almost like a cloudy milky color. I have read that this might be a bacterial bloom? But usually that only occurs if there is a lot of nutrients in the water from what I am reading, but like I said all my params are 0. Is this normal? Thanks for any help.
×