Jump to content

why won't this bulb work?


calvin

Recommended Posts

I ordered a Current USA 70w MH 14000k bulb to replace my current Astralux 14k bulb. I couldn't get the CurrentUSA bulb to fire, so I thought I just got a dud. the replacement came in today and it won't fire either, but my old Astralux bulb still works fine. Anyone got any ideas why Current USA bulbs won't work for me? ( I have an Aromat ballast)

Link to comment

UPDATE:

 

I wound up emailing Ike at CurrentUSA and told him my problem. He suggested I leave the bulb plugged in for a long time. It worked! (why didn't F&S suggest this?) It took almost an hour, but it finally fired up. If this didn't work, Ike was willing to pull a bulb off the shelf, test it himself, and then send it to me. NOW THAT'S CUSTOMER SERVICE!!

Link to comment

I bought 2 sunpods and one takes about 15 minutes to fire while the other fires instantly. Also one bulb looks bluer than the other. I guess their products just vary.

Link to comment

interesting. I finally got my bulb to fire friday, but Saturday it never would even though I left it plugged in for most of the day. so, the old Astralux bulb has gone back in. I'm sure Ike will make it right, though.

Link to comment
supersecretshinto

Is your ballast getting on in years? The time it takes to fire up a bulb can increase as the ballast ages, although I've never seen or heard of it taking fifteen minutes to an hour to light on newer equipment. Might try and use a new bulb the same make as the ones your ballast will fire right away. If it still takes a quite a while longer a weakening ballast may be to blame.

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recommended Discussions

×
×
  • Create New...