Jump to content

aquatop recife eco 24 gal problem


sneekymatt

Recommended Posts

sneekymatt

Basically my return pump's chamber has water filled to the lowest and my filter section of the tank only covers one media box which I dont think is normal? When I first got this tank my pump was good and the chamber was filled decently making little to no noise. Consequently, one day my sister woke me up to tell me that my aquarium was flooded to the brim with water. It looks like the return pump expelled almost all the water in both its chamber and the media bag/box chambers onto the main display area. I took out the water and I took out my pump aswell to see what was wrong with it but I couldn't find anything wrong. But I did have trouble putting it back onto the same place so the tubing kinda expanded which made a bit more noise. 
I honestly do not know what to do and I am desperately looking for help, should i buy a new pump and tubing? Or should I return the tank as a whole to get another one which is a bigger problem because my lfs is like 30 minutes away. 

Link to comment
LazyFish

Check overflow for blockage. Remove filter media may be clogged with debris or have compacted down restricting the flow. If back chambers then fill up that was the cause. Water level may drop more after filling initially. Due to lack of displacement by filter media and evaporation. You may have to add some water.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recommended Discussions

×
×
  • Create New...