Jump to content
DBreefing

Return pump chamber sucking freaking air

Recommended Posts

DBreefing

Hey guys I have an Aquatop Recife 24 g , I took out the sponge in first chamber and added some matrix into the first chamber and my heater. Second chamber has skimmer , third chamber has the media that came with an i added some lava rock.  The return pump chamber doesn’t fill up with water that covers the pump leading up to the tank. Has anyone else experienced this problem and how have you guys mitigate this. 

Share this post


Link to post
Christopher Marks

What happens when you add more water to the system?

  • Like 1

Share this post


Link to post
DBreefing
7 hours ago, Christopher Marks said:

What happens when you add more water to the system?

When I add water to the return pump chamber it just spits it back out to the main display  instead of filling up the return pump chamber ,even if the main system is at Adequate level. It basically tries to overflow the main display.  

Share this post


Link to post
Hasted
18 minutes ago, DBreefing said:

When I add water to the return pump chamber it just spits it back out to the main display  instead of filling up the return pump chamber ,even if the main system is at Adequate level. It basically tries to overflow the main display.  

Does it actually overflow or just gets higher. My display volume goes up half and inch or more when I turn on pump. If my sock, floss, anything is clogged it raises even higher. It is normal for the return chamber to drop when the pump is turned on. Hard to say without being there with you, but I would guess just add more water. 

  • Like 1

Share this post


Link to post
Christopher Marks

Yeah, just keep adding water. If it floods the main display tank, then your overflow is too restricted. The Seachem matrix you added to the 1st chamber might be too restrictive?

  • Like 1

Share this post


Link to post
DBreefing
2 hours ago, Hasted said:

Does it actually overflow or just gets higher. My display volume goes up half and inch or more when I turn on pump. If my sock, floss, anything is clogged it raises even higher. It is normal for the return chamber to drop when the pump is turned on. Hard to say without being there with you, but I would guess just add more water. 

I’ll take a pic to show you 

1 hour ago, Christopher Marks said:

Yeah, just keep adding water. If it floods the main display tank, then your overflow is too restricted. The Seachem matrix you added to the 1st chamber might be too restrictive?

Yeah I think that might it 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recommended Discussions

×
×
  • Create New...