Jump to content
sylocal

Cycling RSR 170 - Zero Readings, Reef Mature Snake Oil?

Recommended Posts

sylocal

Hi Folks,

 

I'm currently in the cycling process of my Red Sea Reefer 170. This is my third tank. I started this tank with BRS Dry Rock, and live sand from BRS.

I added a shrimp 3-4 days ago. It's beginning to disintegrate in my filter sock, still no ammonia readings. I added a small live rock and some chaeto yesterday. Before adding shrimp I began with Red Sea Mature Pro cycling kit however my readings using API & Salifert show to be 0 on everything Ammonia, Nitrate, Nitrite. This is after seven days...

 

77.3 *F
8.17 ph

34.2 salt

233 ORP

 

Visually, the tank looks clean. No signs of diatoms. Where the $#%* is my ammonia haha?!

Either this tank is cycling very efficiently and it's undetectable or Red Sea's Mature Pro cycling kit is pure snake oil.

 

Prove me wrong. What to do next...

 

Edit: I added the live sand and dry rock one week before beginning the cycling product from Red Sea.

 

5C0C331E-D1A4-4F17-A233-EF44799D80C2 2.JPG

Share this post


Link to post
hotdrop

Check NO3 levels they should be slowly creeping up unless you are running a fuge. You should probably also see some NO2 but the test kit for that is shit and not worth paying $8 for. My tank rocks turned green when the cycle finished up, if you are running lights that will probably happen to you too

Share this post


Link to post
Natereef

Buy pure ammonia and dose that and test, if that dont get you ammonia readings I dont know what to say😄. Just to make sure everythings good to go.

Share this post


Link to post
SeaFurn

I've used the Red Sea Mature Pro kit twice and it worked fine.  I followed the day by day directions. 

You shouldn't have needed to added a shrimp to the tank.  The kit comes with something called Bacto-Start - that's the ammonia source.  You would have also added the Nitro Bac - that's the blend of nitrifying and de-nitrifying bacteria spores to seed the tank. 

 

Nonetheless, you should have ammonia right now and so I'm guessing your test kit is bad assuming the test was done correctly.

 

 

Share this post


Link to post
SeaFurn

Also check the expiration on the Red Sea Mature kit. Maybe that is expired.  Another possibility. 

Share this post


Link to post
Clown79

Dosing with ammonia like dr Tim's is easier. That allows you to add a precise amount of ammonia and watch it process until you can process 2ppm in 24hrs.

  • Like 1

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recommended Discussions

×
×
  • Create New...