Jump to content
GrumpyDaddy68

Innovative Marine Spin Stream Nozzles - Too much noise

Recommended Posts

GrumpyDaddy68

Hi all,

I just bought two of these 'Innovative Marine Spin Stream Nozzles ' for a new IM 25 lagoon (tank is in cycling process). I have installed them for testing and I really like the random flow they produce; however, they also produce a clicking noise during rotation that is even louder than the stock pump.

I have seen these nozzle is some of the tanks in my LFS and they don't have this sound.

Does anybody know if this sound will go away at some point? or should return them and try a different type?

 

Thanks for your help,

 

Share this post


Link to post
mattbaar

I had mine on for about a week and the sound went down a little bit but was still the noisiest part of the tank. I returned them and got RFG outlets 

Share this post


Link to post
legomaniac

Mine have never made a sound.  They have been silent since day 1.  Maybe open them up and see if there are any burrs on the plastic gears or the impeller.  Just an idea.

Share this post


Link to post
Clown79

Mine made noise that got better with time but never silent.

 

Never cared much for the type of flow they provided.

I switched to the rfg nozzles which are much better and silent.

Share this post


Link to post
GrumpyDaddy68

I'm afraid mine just might just be defective... I really don't want to open and mess up with them (I might just return them).

I probably with go with the RFGs (prices range is about the same).

 

Thanks all,

 

Share this post


Link to post
Clown79
3 minutes ago, GrumpyDaddy68 said:

I'm afraid mine just might just be defective... I really don't want to open and mess up with them (I might just return them).

I probably with go with the RFGs (prices range is about the same).

 

Thanks all,

 

Ya not sure about opening them.

Many complain about the noise.

They do have small parts in them that can easily break.

Share this post


Link to post
|n0_0ne|

They get quieter over the course of a few weeks and end up silent. Just need a break in period. If it’s been longer than that squeeze the sides to disassemble and put it back together. That usually does it. 

Share this post


Link to post
SliceGolfer

Mine took two months before they were dead silent. I did reverse the gear in one so I have two random opposing flows.

Share this post


Link to post
GrumpyDaddy68

Thanks,

I did return them and now I am waiting for the RFGs.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recommended Discussions

×
×
  • Create New...