Jump to content
DSFIRSTSLTWATER

Tidal 55 question

Recommended Posts

Hey guys, so I've been running the tidal 55 for a few months now and I was wondering if you use the seachem matrix? If you do, do you clean it out or rinse it off often? Can I just take it out and run my filter floss and chemipure?
I have had it in the whole time and it is getting pretty cruddy. I rinsed it in water old water change water, but it didn't really come clean. I'm getting more hair algae then I'd like and the only thing that hasn't changed is that bag of matrix. Floss gets changed at least twice a week and i do dump the filter once a month. Just wondering what you guys do or don't do.

 

Thanks Dave🙂

 

Share this post


Link to post

Matrix is meant to be rinsed regularly or it will buildup detritus. It does not need replacement.

 

Seachem instructions:

 

Matrix™ is completely inert and will not breakdown. It need not be replaced. Since the majority of the bacteria are internal, Matrix™ may be rinsed when needed without damaging the filter. Matrix™ is compatible with all types of wet or wet-dry filters.

 

 

 

If you haven't been rinsing the bag of matrix, the buildup would be a lot.

 

 

It's also beneficial to suck out with a Turkey baster buildup of particles in the filter every other waterchange. This prevents buildup on the media bags.

 

I didn't use the matrix with my tidal because I had enough rock in the tank.

 

 

  • Like 2

Share this post


Link to post
6 hours ago, Clown79 said:

Matrix is meant to be rinsed regularly or it will buildup detritus. It does not need replacement.

 

Seachem instructions:

 

Matrix™ is completely inert and will not breakdown. It need not be replaced. Since the majority of the bacteria are internal, Matrix™ may be rinsed when needed without damaging the filter. Matrix™ is compatible with all types of wet or wet-dry filters.

 

 

 

If you haven't been rinsing the bag of matrix, the buildup would be a lot.

 

 

It's also beneficial to suck out with a Turkey baster buildup of particles in the filter every other waterchange. This prevents buildup on the media bags.

 

I didn't use the matrix with my tidal because I had enough rock in the tank.

 

 

Thanks for the info Clown :smilie:. I actually forgot that I had posted this lol. I ended up taking it out over the weekend. After doing some reading I assume that's where my issue has been. I just figure take it out and let it ride with floss and chemipure. I'm gonna watch it for a week and I'm guessing i'll notice a difference. I'm going to update my tank journal with my findings so if someone else comes across maybe it'll help them too.

  • Like 2

Share this post


Link to post

If you have liverock in the tank, I can't imagine removing the matrix will make much difference.

  • Like 1

Share this post


Link to post
6 minutes ago, Clown79 said:

If you have liverock in the tank, I can't imagine removing the matrix will make much difference.

It's funny because when I set the filter up I lookd at it and wasn't even going to put it in, changed my mind and well now I have algae lol. Lessons learned through trial and error.

Share this post


Link to post
58 minutes ago, DSFIRSTSLTWATER said:

It's funny because when I set the filter up I lookd at it and wasn't even going to put it in, changed my mind and well now I have algae lol. Lessons learned through trial and error.

I loved the filter. Best one I ever used and I've used a lot over the years.

Even the media itself isn't an issue. I use it in my 5g.

 

It's not the filter that caused algae but not cleaning media bags and not properly cleaning filters leads to nutrients due to detritus buildup.

 

Same thing will happen in an aio back chamber and sump.

  • Like 1

Share this post


Link to post
22 minutes ago, Clown79 said:

I loved the filter. Best one I ever used and I've used a lot over the years.

Even the media itself isn't an issue. I use it in my 5g.

 

It's not the filter that caused algae but not cleaning media bags and not properly cleaning filters leads to nutrients due to detritus buildup.

 

Same thing will happen in an aio back chamber and sump.

lol I actually bought it because you said you really liked it. I love that thing, it has so much room for media. Yeah I was on top of the cleaning of it just not the matrix...for some reason I would gloss over it and well now it bit me lol

lesson learned :smilie:

Share this post


Link to post
45 minutes ago, DSFIRSTSLTWATER said:

lol I actually bought it because you said you really liked it. I love that thing, it has so much room for media. Yeah I was on top of the cleaning of it just not the matrix...for some reason I would gloss over it and well now it bit me lol

lesson learned :smilie:

It's a fixable issue. Nothing drastic.

  • Like 1

Share this post


Link to post
12 minutes ago, Clown79 said:

It's a fixable issue. Nothing drastic.

So since I fixed the the source, how long til it clears up you think? I have been scrubbing those damn rocks for months while I was trying to figure out what happened. Think it'll just wither away in a month or so?

Share this post


Link to post

Dive in and share your thoughts!

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recommended Discussions

×