Jump to content
Heydude

Zoanthid Snail

Recommended Posts

Heydude

Any advice, 

 

Lights have just come one and I've noticed half my colony of Zoa not opening and appear to have what I can only describe as a furry looking coat around them. 

 

On closer inspection I found the little critter in the picture, small snail?

 

Could this be the cause of this, should I do a freshwater or peroxide dip, or something else?

 

Snail wise in the tank I have Astrea, Nassarius and Cerith. 

 

Thanks in advance. 

20180311_131557_HDR.jpg

20180311_131235_HDR-1.jpg

Share this post


Link to post
Heydude
19 minutes ago, CSreefer said:

ITs called a sundial snail and it’s a hitchhiker  more info in this link

http://www.coralrx.com/index.php?option=com_content&view=article&id=18&Itemid=16

 

good luck!!?

Thanks, appreciated, love the way there is always someone in here ready to help with the answer. 

 

The article says about quarantine, unfortunately I don't have one,  newbie and at present only have a small 8g tank. 

 

Just been reading another article now that I know what it is and that says they can be quite resistant to dip and manual removal is best.

 

Hopefully it's the only one  but will be vigilant and if it does appear to be more than that I will do a dip. 

  • Like 1

Share this post


Link to post
CSreefer

Good luck! I hope your zoas pull through!

  • Thanks 1

Share this post


Link to post
Heydude

Hi all, 

 

So far so good, have found 4 snails and manually removed them and the colony is looking good. 

 

Upon inspection I've noticed an anomaly, in the image attached if you look closely where the white sort of line is there seems to be something pulsing from it, now I can't say for certain that this 'White sort of Line' thing has always been there, but never seen any sort of pulsing, it's not easy to see with the naked eye, it's only as I take images to check for more snails that I saw it. 

 

Question is, do you think it's yet another critter or possibly some form of coral, I have noticed on the other side of the colony what appears to be a couple of Xenia looking polyps. 

20180326_165434_HDR.jpg

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recommended Discussions

×
×
  • Create New...