Jump to content

Skimmer problems!


dixie reefer

Recommended Posts

I have a Reef Octopus BH-50 INT nano skimmer. This is my first ever skimmer. Why is it that when I turn it on, the water level in my sump drops drastically and it rises in my dt? The dt is a 29 gal, sump is 10 gal, return pump us a mag 7.

Link to comment

hm. We'll see if I have the same issue when I put my Aquaticlife skimmer in the sump this weekend. I also have the mag 7.

 

I don't know about that skimmer but does your return pump make it hot? I have the same and I'm hooking up my 34 to the refugium and overflow this Sat and I just had the pump in the 10g sump to cycle it and it's been like 82 so I turned the heater in the fuge down to 72 and it's now been 78 in there.

Link to comment

I don't have experience with this, so take this with a grain of salt, but it sounds like your overflow box/design can't keep up with amount of water the skimmer and return pump are pushing? I could be way off. I probably am.

Link to comment

What type of overflow do you have? I'm trying to understand why this only happens when your skimmer is turned on. Post some pics or a youtube video

Link to comment

I have the IM gadget skimmer that goes with my Nuvo 16 and I hate that $^%(@*er, practically threw it on the floor this morning after we spent the whole morning trying to get it to work. The cup kept filling with water no matter how we tried to tweak the venturi and the cylinder. Good luck. I'm not even going to try mine any more.

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recommended Discussions

×
×
  • Create New...