Sign in to follow this  
Followers 0
lucky38422

Difference between buying seawater and making saltwater

So I have been buying the water from petco, it's their brand and have had no issues. I recently decided to make my own water using reef crystals. For some reason the water looked rather yellow. It tested fine though. I decided not to put it into my tank, but was wondering if anyone else has ever had this issue, and is it even an issue?

Share this post


Link to post
Share on other sites

Sounds like you may not be mixing it long enough. What is your process for mixing it?

 

Powerhead and heater in a container for 18-24 hours to properly mix it and heat it to tank temperature is the general procedure.

 

Check PH as well.

Edited by Chrisl1976

Share this post


Link to post
Share on other sites

nothing really, besides knowing what the base water was and what salt is going in it. I'd look at maybe using an LFS for water if you don't want to mix your own. Leave a little room in the container to add water or salt to ensure it's SG is adjusted properly.

Share this post


Link to post
Share on other sites
Sounds like you may not be mixing it long enough. What is your process for mixing it?

 

Powerhead and heater in a container for 18-24 hours to properly mix it and heat it to tank temperature is the general procedure.

 

Check PH as well.

 

That's what's crazy, I used a heater and a power head. Let it mix for 24 hrs as well. And the bucket was clean lol. It was really odd.

Edited by lucky38422

Share this post


Link to post
Share on other sites
That's what's crazy, I used a heater and a power head. Let it mix for 24 hrs as well. And the bucket was clean lol. It was really odd.

 

city water? well water?

Share this post


Link to post
Share on other sites

what kind of water did u mix with the salt? tap, ro, rodi, distilled? i use reef crystals and the water is cloudy for a few minutes while mixing but never yellow. Also what kind of container did u mix it in?

Share this post


Link to post
Share on other sites
what kind of water did u mix with the salt? tap, ro, rodi, distilled? i use reef crystals and the water is cloudy for a few minutes while mixing but never yellow. Also what kind of container did u mix it in?

 

 

I used ro/di. And I used a 5 gal bucket, made about 3 gal of water.

Share this post


Link to post
Share on other sites

i dont know then. maybe the lfs sold you some bunk RODI. it can only be one of three things. bad water, bad bucket, or bad salt. sorry i couldnt help more

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0