Jump to content
Sign in to follow this  
Madcrabber

jbj 28g LED intermediate light issues

Recommended Posts

I have the 28g nanocube LED stock lighting and have had issues with the daylights now two times in the past month. When I turned the lighting on for the first day..the daylights went out. I called JBJ they were great and sent me a new hood. I upgraded my powerstrip just in case and started using the new hood they sent me....it has been running for about a little under two weeks and just blew again...The moon lights work, the fans work, but the daylights went out. I smelt a burning smell this time....I will be calling JBJ but in the mean time...any suggestions? Does this happen often?

 

Thanks!

Edited by Madcrabber

Share this post


Link to post

This just happened to me today! I was sitting in my office, where I keep my JBJ 28g Nano LED Intermediate, when I heard a pop as the daylight LEDs went out on my aquarium, followed immediately by a burning smell. Moon LEDs and fans still work. My tank has been running for about 2 weeks....

 

How long did it take to get a replacement hood?

 

Sounds like a fairly common problem with the JBJ 28 LED Interm.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  
  • Recommended Discussions

  • Sign Up or Sign In to hide this.

×