ag1129

BTA Hiding?

I just got a BTA from Live Aquaria and I put it in my tank, did the normal acclimation process and it seems to have moved into a cave within my live rock? Is this normal? It's been in the tank for about 24 hours....could my lighting be too strong for it right now? I have a 150w 20k MH in a 27 gallon tank that measures 21x21x20. Any ideas of whats going on?

Share this post


Link to post
Share on other sites

its just acclimating itself leave and watch it should be fine. sometimes they dont like that much light and take some time to get use to it

Share this post


Link to post
Share on other sites

My tube nem left its tube, hid behind rocks and now growing a new tube. Would've been easier to just hide two $20 bills behind that rock. heh

 

You can't really force these things to be where you want them to be. They will chose the best spot, just give them time.

Edited by solefald

Share this post


Link to post
Share on other sites

Alright hopefully it'll come out in a few days! Thanks for your help, it puts me at ease!

Share this post


Link to post
Share on other sites

not a expert by any means but when i had my bta it 'hid' pretty deep in the rocks but you could see it strech its food out about 4-5 inches when it wanted light or food.

Share this post


Link to post
Share on other sites

I have had mine do the same but more of a peek a boo act. Normal adjustment process.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now