Jump to content

Help weird brown algae stuff


Adzski

Recommended Posts

Hey well I think it was last satday I purchased and anemone and a Frogspawn all I's well except for that last cpl days I've noticed massive algae build up and had a fish die :( tested the water it was perfect I think it had a disease but back to the brown algae it's on the sanded and live rock I really don't no what it Is please Help

Link to comment
Hey well I think it was last satday I purchased and anemone and a Frogspawn all I's well except for that last cpl days I've noticed massive algae build up and had a fish die :( tested the water it was perfect I think it had a disease but back to the brown algae it's on the sanded and live rock I really don't no what it Is please Help

 

How long has your tank been set up? How long was it set up before you put the nem and frogspawn in? What size tank, lighting, and your params? (ammonia, nitrite, nitrate, temperature, salinity?) it sounds like you didn't properly cycle before you introduced your livestock if I had to guess and/or added your stuff too quickly. Sounds like a diatom bloom, absolutely normal for a new tank.

 

You should return the nem asap as it will more than likely die under the care of a new enthusiast. They are usually reserved for experts with stable parameters and great lighting.

 

Good luck, gotta absolutely take it slow and read up on your stuff

Link to comment

ive had the tank for about 3-4 months cycled and i put put the nem in around the 4 month mark its a 10 gallon the lighting i have is a T5HO 4X24Watt. i tested tested the water today was perfect except the ammonia was a little high so i bought some stability stuff to bring it down put it in the tank today.

Link to comment
ive had the tank for about 3-4 months cycled and i put put the nem in around the 4 month mark its a 10 gallon the lighting i have is a T5HO 4X24Watt. i tested tested the water today was perfect except the ammonia was a little high so i bought some stability stuff to bring it down put it in the tank today.

 

If the ammonia is high your water is far from "perfect".Ammonia is highly toxic and should be undetectable in a fully cycled tank. How much live rock have you had in there from the beginning?The "brown algae" sounds like diatoms.As far as the anemone they need sps quality lighting and general tank conditions and also a larger tank. IMO take it back and don't buy anything else until all tank parameters are completely stable.Ammonia and nitrites should both be undetectable.Good Luck!!

Link to comment

Don't add chemicals.

 

Figure out where your ammonia is coming from (dead fish) and correct it. Once the fish has been removed, the tank will balance the ammonia itself.. again.. DON'T ADD ANY CHEMICALS waste of money.

 

Also, you'll probably need to take the nem back, because, as mentioned, most get way too big for a 10g.

 

Some don't, and some don't need insane lighting.. but you didn't specify what you got, so we can probably assume it's one that will and does :P

Link to comment

hey guys tested the water and results were

 

pH-8.0

ammonia(NH3/Nh4)-0ppm

Nitrite(No2)-0ppm

nitrite(No3)-10ppm

 

and i took the nem back was a actual crazy story but yeh i took it back

Link to comment

well when i woke up the next moring i noticed my two clowns were missing and at first i thought they jumped but i looked and were no where to be seen and i looked in the tank and when i got the nem out of the tank i noticed a something orange and looked closely and it turned out it was the clown and on the way back to the LFS it actually started spitting out the clown but i was still missing another clown and after lifting the Liverock up i found him dead and missing a big chunk out of its side looked like something took a big bite out of it i am still baffled to what it could of been and i have no idea why they died? they were very healthy the night before?

my story may seem far fetched but its the truth

Link to comment

i also have another question i have brown/gold algae on my DSB and my Live rock and small air bubbles are come from the DSB ive read cleaving the algae of the rock every day and a water change every day will fix this is this true or you have anyother suggestions?

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recommended Discussions

×
×
  • Create New...