Jump to content


Photo

Cleaner shrimp . Mysterious spot!


  • Please log in to reply
1 reply to this topic

#1
Alexraptor

Alexraptor

    Stomatopod in a human suit!

  • Members
  • 1,712 posts
  • Joined 27 Feb 2005

Hi guys! In urgent need of some help here!

Ive had these two cleaner shrimps for about 5 months, and they have been at the peak of health.
But today suddenly while re-aquascaping a bit today I suddenly noticed that one of my cleaners had this strange unknown spot/blotch or lesion.
His behavior is fine, he does not seem in any kind of distress and is acting completely normal, just like any other day.
Water parameters are all fine, and my cleaners have no prior history of health issues during the entire 5 month period.
And I have not added anything at all to the tank, period, since then, no livestock, no rock, nothing!
This mark seems to have cropped up out of nowhere in the last 24-48 hours.

Specific gravity: 1.026
PH: 8.3
Alk: 9 dkh
Calcium: 400 ppm
Magnesium: 1350 ppm
Ammonia: 0
Nitrite: 0
Nitrate: 0
Phosphate: 0

Would be really happy if someone could shed some light on this, thanks!

Attached Thumbnails

  • cleanerunknownspot2.jpg
  • cleanerunknownspot.jpg

Edited by Alexraptor, 09 April 2012 - 07:42 AM.


#2
Alexraptor

Alexraptor

    Stomatopod in a human suit!

  • Members
  • 1,712 posts
  • Joined 27 Feb 2005
Resolved.
Covered my bases and posted on multiple places.

Bob Fenner at WetWebMedia thinks that its environmental possibly an iodine deficiency.
Most likely not a parasite, which kind of was my main concern.